forked from emily/nixfiles
16 lines
340 B
Nix
16 lines
340 B
Nix
{ pkgs, ... }:{
|
|
boot.loader = {
|
|
systemd-boot.enable = true;
|
|
efi.canTouchEfiVariables = true;
|
|
};
|
|
environment.systemPackages = with pkgs; [
|
|
pciutils
|
|
usbutils
|
|
];
|
|
hardware.cpu.intel.updateMicrocode = true;
|
|
hardware.enableAllFirmware = true;
|
|
|
|
kyouma.machine-type.physical = true;
|
|
|
|
services.fwupd.enable = true;
|
|
}
|