forked from emily/nixfiles
23 lines
970 B
Nix
23 lines
970 B
Nix
{ lib, pkgs, ... }: {
|
|
kyouma.deployment.auto-upgrade.cache = "daemon";
|
|
nix.settings = {
|
|
trusted-users = [ "nix-ssh" ];
|
|
#system-features = [ "nixos-test" "benchmark" "big-parallel" "kvm" ] ++ lib.optionals pkgs.hostPlatform.isx86_64 [ "gccarch-x86-64-v3" ];
|
|
};
|
|
nix.extraOptions = ''
|
|
min-free = ${builtins.toString (16384 * 1024 * 1024)}
|
|
max-free = ${builtins.toString (32768 * 1024 * 1024)}
|
|
max-substitution-jobs = 30
|
|
max-silent-time = 14400
|
|
'';
|
|
nix.sshServe = {
|
|
enable = true;
|
|
write = true;
|
|
keys = [
|
|
"ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIA/+iN407+HsfHbbC3tfdA8Yf4TZ08qXQMb4tb/SDAs+ emily@card"
|
|
"ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIE/vCXM3IaxJP9v2Y+xcQrQD2IcffgdzqtWhpMjj9Xl5 hydra@seras"
|
|
"ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAICT0dGyLUjxFnvqUmex+5xUGQ7D4yGHKo267JgApcq0k root@ryuuko"
|
|
"ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIIDTwCSWYODyvTJxwB6Rahuy0j6s/YYwtQta8bjzG/We root@ryuuko-arch"
|
|
];
|
|
};
|
|
}
|