moderation/flake.nix
2024-11-14 19:11:10 +01:00

33 lines
964 B
Nix

{
inputs.nixpkgs.url = "github:NixOS/nixpkgs/nixpkgs-unstable";
outputs = { self, nixpkgs, ... }: let
inherit (nixpkgs) lib;
in {
nixosModules = {
default = import ./module.nix;
florp = args: {
services.akkoma.moderation = import ./florp.nix args;
};
};
nixosConfigurations.testEval = lib.nixosSystem {
system = "x86_64-linux";
modules = [ {
system.stateVersion = "24.11";
networking.hostName = "hostName";
networking.domain = "domain";
fileSystems."/".device = "nodev";
boot.loader.grub.enable = false;
services.akkoma.enable = true;
services.akkoma.config.":pleroma" = {
"Pleroma.Upload".base_url = "nonEmptyStr";
":instance" = {
name = "test";
description = "test";
email = "test@test.test";
};
};
} ] ++ (with self.nixosModules; [ default florp ]);
};
};
}